This page provides you with information about SkyDesk updates/maintenance and issues.

Discontinuation of support for TLS 1.0/1.1 and RC4 [preannouncement]

Nov 12, 2018

(November 12, 2018: Updated the support ending date from Oct. 31 to Nov. 30.)
(September 4, 2018: Updated the support ending date from the end of August to the end of October.) 
(August 24, 2018: Released new SkyDesk Reports Upload Tool that supports TLS 1.2.)
(July 18, 2018: Updated the support ending date from the end of September to the end of August and added description about RC4.)
(May 31, 2018: Updated the support ending date from the end of July to the end of September.)
(May 30, 2018: A description about SkyDesk Reports Upload Tool was added.)

 

Dear customers,

Thank you for using SkyDesk. We greatly appreciate your business.

We will be ending the support for cryptographic internet protocol TLS 1.0 and TLS 1.1 on November 30, 2018. 
After this date, users with old browsers, smartphones, tablets and other devices which do not  support TLS 1.2 will not be able to use SkyDesk services (including APIs).

 

  • For customers using PCs:

Applicable OSs

Windows XP and earlier, Windows Vista and earlier, MacOS X 10.8 and earlier
Need to update to new OS

Applicable browsers

Internet Explorer 10 and earlier, Chrome 29 and earlier, Firefox 26 and earlier, Safari 7 and earlier
Need to up update to new browser
If TLS 1.2 is not enabled in the browser settings, it must be enabled

  • For customers using smartphones:

Applicable OSs

Android 4.4 and earlier, iOS 5.0.1 and earlier, Windows phone 8.0 and earlier
Need to update to new OS

Applicable browsers

Chrome 29 and earlier, Firefox 26 and earlier
Need to up update to new browser

  • For customers using APIs:

The environments using APIs must support TLS 1.2
Applicable environments

Java 6u45 and earlier,
Java 7u25 and earlier,
OpenSSL 0.9.8y and earlier,
.NET 4.5 and earlier (settings should be changed to enable TLS 1.2)

  • For customers using SkyDesk Reports Upload Tool:

We have released new SkyDesk Reports Upload Tool that supports TLS 1.2. Since past versions of Upload Tool will be unavailable after November 1, 2018, please download the latest version and use it. 

 

On November 30, 2018, we will also be ending the support for stream cipher RC4 in SkyDesk Mail . 
After this date, users with old email clients which only support RC4 will not be able to send or receive emails.

  • For customers using email clients:

If your email client supports only RC4, you must move to newer email clients.

 

Please note that, not using the applicable environments mentioned above does not mean that there are no security risks. OS and browsers are constantly updated to reduce security risks. To stay safe and secure, please check your OSs, browsers, and environments and apply the necessary updates.

Recommended operating environments for SkyDesk are listed below:
https://www.skydesk.jp/legal/terms/agreement.html

As notified earlier, SkyDesk Support has ended the support for Internet Explorer 11 on June 15, 2018. Please note that we are likely to discontinue support for Internet Explorer on other SkyDesk Services as well, so we recommend you to move to other supported environment in this occasion.